Opzioni di Borsa in laboratorio – 16 – DEMA e TEMA in Excel

rubrica: 

Quando Mr. Mulloy presentò il suo nuovo Indicatore in Technical Analysis of Stocks & Commodities nel ’94, non si accorse di aver creato un equivoco nel battezzarlo DEMA.

Infatti, a rispetto dell’acronimo <DEMA = Double Exponential Moving Average>, è facile pensare che si tratti semplicemente della ‘media di una media’ mentre in realtà è la sintesi di una singola media con un’altra doppia media.
Prima però di spiegare come realmente funzionino DEMA e il suo cugino TEMA, dobbiamo fermarci per fare una critica costruttiva alle Medie Mobili. Semplici, Esponenziali o anche Triangolari o Pesate che siano, il problema di fondo è che nelle Medie Mobili più aumenta il Time Period (per esempio lo portiamo da 14 a 24) e più aumenta il tempo che serve per smuovere la media stessa. In parole più semplici: per ottenere una indicazione di trend di lungo periodo, come ormai sappiamo, è necessario aumentare il valore K1 ma così facendo, prima che la media si giri dalla parte giusta, il mio tempo di attesa è cresciuto talmente che quando entro sul mercato ormai è tardi; stiamo parlando dell’annoso problema della coperta corta: se la tiri verso la testa, è la volta buona che ti scopri i piedi.
Mulloy (e non solo lui) si era accorto che il vecchio MACD faceva acqua e questo perché le Medie Mobili con cui è costruito hanno un cattivo livello di ‘smorzamento’. E allora Mulloy che fa? Con una serie di accorgimenti che seguiremo in Excel, egli trova il modo di accorciare il ritardo.
Come vedremo alla fine, Mulloy è stato fin troppo bravo perché il suo DEMA è quasi fin troppo reattivo: ottimo lavoro! Complimenti!
 
Come al solito partiamo dalla fine e vediamo DEMA e TEMA sul recente Ftsemib.
Analogamente all’RSI e al MACD, anche DEMA funziona con la sola close (niente open, high e volumi) … peccato!

Con K1 impostato a 21 (valore di default proposto dall’autore), scopriamo la prima colonna intitolata EMA(K1), cioè costruiamo la media mobile esponenziale a 21 giorni che già siamo esperti a calcolare:

Memorizziamo in cella J5 il calcolo della exponential percentage: EMA(21) = 2/(21+1)
Il calcolo porta a 0,090909 mentre il complemento a 1 che mettiamo in K5 è: 0,909091
 
La formula di EMA(K1) è la seguente: =SE(RIF.RIGA()=11;E11;E11*$J$5+G10*$K$5)
Se sei all’inizio (riga 11) metti la chiusura, diversamente moltiplica la chiusura per la E.P. e sommala con la EMA del giorno precedente moltiplicata per il complemento di E.P.
 
Fin qui nulla di nuovo: abbiamo creato una colonna con la EMA di 21 periodi.
Ora un passo avanti: creiamo la EMA(k1) della precedente EMA(K1)

Il calcolo comincia solo a livello del 31 gennaio perché i giorni precedenti rappresentano il volano che accumula i dati.
Ecco la formula in chiaro:
=SE(RIF.RIGA()<$B$1+11;"";SE(RIF.RIGA()=$B$1+11;G32;G32*$J$5+H31*$K$5))
 
E qui siamo al risultato finale: Mulloy intuisce di mettere sulla bilancia i pesi per così dire “in proporzione temporale”.
E come fa?
Semplice: pesa 2 volte la EMA (per così dire: “tradizionale”) e 1 volta soltanto la EMA della EMA.
Il risultato è lo schiacciamento del ritardo.   E bravo Mulloy!
 
Formula di DEMA:   =SE(H32="";"";2*G32-H32)
 


Non pago dei risultati, l’autore procede con la terza EMA creando così TEMA (Triple EMA).
Per vederla è necessario aspettare i primi 21+21=42 giorni di latenza.

L’algoritmo di TEMA è:
 
 
 
Per non fare pasticci nella spiegazione, ho pensato che farete prima a seguirla voi personalmente sull’excel che trovate in allegato.
 
Conclusione: i risultati di DEMA e TEMA non si discostano particolarmente e questo lo si vede già dal grafico.
Posso dire che dal 29 febbraio 2012 al 12 giugno la massima differenza tra DEMA e TEMA si è verificata il 16 aprile con 455 punti, ben poca cosa rispetto ai valori correnti dell’Indice  (circa il 3% … neanche uno strike!).
Volendo considerare gli Indicatori visti finora:
 

  • Tra MACD e DEMA/TEMA io sceglierei assolutamente gli ultimi due (uno vale l’altro)
  • RSI ci racconta solo qualcosa in merito all’ipercomprato/ipervenduto
  • AROON merita una nuova lezione a parte ma la faremo più avanti, via via che parleremo di altri Indicatori e stringeremo il campo di osservazione

 
Non so ancora cosa vedremo la prossima volta, probabilmente faremo l’Oscillatore di Marc Chaikin in cui, finalmente, entrano in gioco i volumi delle sedute di Borsa.
 
Non mancate all’appuntamento!
 
 
Francesco Caranti